Boost logo

Boost :

From: Ed Brey (brey_at_[hidden])
Date: 1999-08-17 16:18:50


I can see it being convenient to pull all the integer types into the
current namespace in one operation. To that end, I'd like to propose
that cstdint.hpp change to look like this:

#ifndef BOOST_CSTDINT_HPP
#define BOOST_CSTDINT_HPP

namespace boost
{

namespace integer_types
{
#include <boost/stdint.h>
}

using namespace integer_types;

} // namespace boost

#endif // BOOST_CSTDINT_HPP

This would allow a particular function to do something like this:

void fn()
{
        using namespace boost::integer_types;

        int_least8_t var1;
        uint32 var2;
        ...
}

In general, I think this kind of sectioning would be useful for
groups of related names that show up in "utility" libraries like
cstdint.hpp.


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk