From: Aleksey Gurtovoy (alexy_at_[hidden])
Date: 2000-02-06 15:04:58
Greg Colvin <gcolvin_at_[hidden]> wrote:
> From: Stephen C. Gilardi <squeegee_at_[hidden]>
> > Perhaps names more inline with the intention of temporarily setting a
> > value and being assured that it will be restored at the end of the
> > block would be"
> > "scoped_push_value" or
> Which fits with scoped_ptr. Perhaps just scoped_value would do?
Wow, Greg! I think you've found a very good name for my original class. At
least your name reflects a usage of the class in way I wanted to achieve
with my lame 'temporary_value':
boost::scoped_value<bool> in_scope( disable_updates_, true );
But it doesn't fit to 'set_on_exit' semantics. May be we indeed need two
different classes with good descriptive names?
Boost list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk