Boost logo

Boost :

From: Kevlin Henney (kevlin_at_[hidden])
Date: 2000-11-07 13:59:42


In message <4.3.2.7.2.20001107124740.00b8cf20_at_[hidden]>, Beman
Dawes <beman_at_[hidden]> writes
>I'm trying to discover if it makes sense to have two conventions, one for
>implementation artifact macros, and another for public interface macros. I
>don't see that as arrogant, just trying to find a better way.
[...]
>Maybe I'm the only one who finds it really jarring to see
>BOOST_STATIC_ASSERT as a function name in the middle of mainline code, and
>would like to find a better convention.

Well, I find it jarring to see macros, period, so a looming BOOST_ is
not going to sway me away from upper case. However, perhaps we could
consider BOOST_DETAIL_ as the prefix for internal macros.

>Perhaps I should just work on a core proposal for a new language
>feature. All of the macro uses we are talking about are needed to get
>__FILE__ and __LINE__. How about two new special symbols:
>
>namespace boost {
> static_assert( bool exp, const char * file=__FILE_AT_USE,
> int line=__LINE_AT_USE );
>}
>
>The compiler is required to replace these with the appropriate value at the
>point of a call to static_assert(), rather than at point of declaration.

And these would be constrained only to arg lists? Otherwise, I think we
have some interesting ODR issues. Interesting idea.

Kevlin
____________________________________________________________

  Kevlin Henney phone: +44 117 942 2990
  Curbralan Limited mobile: +44 7801 073 508
  mailto:kevlin_at_[hidden] fax: +44 870 052 2289
  http://www.curbralan.com
____________________________________________________________


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk