Boost logo

Boost :

From: Gary Powell (Gary.Powell_at_[hidden])
Date: 2000-12-04 17:58:41


> Ed Brey wrote:
> > 4. There was previous discussion regarding a nested namespace for
> integer
> > types; however, that didn't seem to make it into the latest version of
> > cstdint.hpp. I'd propose the following addition to provide the nested
> > namespace to those who use it without causing any effect on those who
> don't.
> > Before the close of the boost namespace, include:
> >
> > namespace integer {
> > using int8_t; using int_least8_t; using int_fast8_t; using uint8_t;
> > using uint_least8_t; using uint_fast8_t;
> > // ... and so on for 16, 32, and 64 bit, intmax_t, and intmin_t.
> > }
>
> Before going ahead, I would like to have some more opinions on this.
Ok, I'd rather break user code and move these types into a nested namespace.
The name "integer" is fine by me. And post this above snippet for users to
include who can upgrade to the latest boost source who would otherwise not
be able to change their source, yet can still recompile. (Are there any such
users?)

Name conflicts are only going to get worse. IMO its better to fix these
things earlier rather than later. This is one of the benefits of not being a
"standard" library. If we get wrong we apologize, fix it and let the cards
fall where they may.

> > IMHO, the same technique and nested namespace should be used in
> integer.hpp.
Same argument.

  -gary-


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk