Boost logo

Boost :

From: jhrwalter (walter_at_[hidden])
Date: 2002-03-14 05:20:53


--- In boost_at_y..., Toon Knapen <toon.knapen_at_s...> wrote:
> Although ublas throws an exception when e.g. multiplying
incompatible
> matrices, it does allow asking for a non-existant row
> e.g.
> matrix< double > a(8,3);
> row( a, 200 ); // does not assert, throw, ...
 
If you're talking about a debug mode executable, this would be a bug
IMO. In release mode (NDEBUG defined) every precondition check ought
to be disabled. I'll look at this.
 
> Since performance is crucial, I would prefer to have asserts
protect mis-use
> of the lib.

Agreed, the default implementation of the precondition checks will
use assertions in the next release.
 
> BTW, when are you planning to change size1() and size2() into
num_rows and
> num_cols (as suggested by Jeremy and IIRC you accepted)
 
Thanks for the reminder ;-) I'm not very happy with this change, as
it breaks the libraries internal naming scheme, but if nobody
objects, I'll change this soon.
 
Regards
 
Joerg
 


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk