Boost logo

Boost :

From: Paul Mensonides (pmenso57_at_[hidden])
Date: 2003-01-05 16:17:08


----- Original Message -----
From: "Paul Mensonides" <pmenso57_at_[hidden]>

> Vesa, I hack this up so it works on all compilers and then add it to the
> CVS. The main problem is that the implementation relies on expansion
order.
> That is another name for "VC and Metrowerks bugs." I don't see why they
> can't be worked around though.

Vesa, I can get it to work on VC and Metrowerks if I alter the semantics
slightly. Namely by doing this:

#define IS_ZERO(x) IS_ZERO_I( CHECK x () )
// ...

#define CHECK() 1

The semantic change is that 'x' must not be a function-like macro. What do
you think?

Paul Mensonides


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk