Boost logo

Boost :

From: Douglas Gregor (gregod_at_[hidden])
Date: 2003-05-02 08:57:35


On Friday 02 May 2003 09:23 am, David Abrahams wrote:
> Beman Dawes <bdawes_at_[hidden]> writes:
> > * What header naming convention?
> >
> > ???? Note that users can pick and choose an implementation by header
> > choice, even if we use namespace std::tr1.
>
> Same as the standard, plus .hpp.

By "plus .hpp", do you mean "append .hpp to the filename" or "standard header
names and the standard header names with .hpp appended"? I think I would like
to see:
  
In boost/tr: functional.hpp, tuple.hpp, etc.

in boost/tr/std: functional, tuple, etc. as specified in the TR. Each of these
files might look like this <functional> header:

#ifndef BOOST_TR_USE_STD_NAMESPACE
# define BOOST_TR_USE_STD_NAMESPACE
#endif

#include <boost/tr/functional.hpp>
#include_next <functional>

Needs some testing, but in theory this would let the Boost TR be a drop-in TR1
component for any standard library as long as the compiler supports
#include_next.

        Doug


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk