Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2004-02-29 09:13:45


Daniel Frey <d.frey_at_[hidden]> writes:

> Eric Niebler wrote:
>> boost::std_min is defined as follows:
>> template< typename T >
>> inline T const & std_min( T const & a, T const & b ) {
>> using std::min;
>> return min BOOST_PREVENT_MACRO_SUBSTITUTION ( a, b );
>> }
>
> I don't like the name of the function, as std_min doesn't hint me
> about the ADL-nature of the call. Would adl_std_min be too much
> typing? Or propbably just adl_min, as it's quite common to use
> std::min if ADL doesn't find a better match. My $.02.

Looks to me as though boost::min_ is the best name for this thing.

-- 
Dave Abrahams
Boost Consulting
www.boost-consulting.com

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk