From: JOAQUIN LOPEZ MU?Z (joaquin_at_[hidden])
Date: 2005-02-03 14:51:54
With the recent addition of TR1 aligned_storage to
Boost.TT, there's a nasty collision with a class named
exactly the same and living in boost/aligned_storage.hpp
(this class is a spin-off from Boost.Variant, IIRC.)
I think this has been discussed some months ago, but
with no resolution to the best of my knowledge.
Apart from the symbol clash, these two classes do not
provide the same functionality, so I guess it'd be sensible
to rename the older aligned_storage to something else.
Joaquín M López Muñoz
Telefónica, Invstigación y Desarrollo
Boost list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk