Boost logo

Boost :

From: Eric Niebler (eric_at_[hidden])
Date: 2005-03-23 17:00:59


Thorsten Ottosen wrote:
> This changes the extension protocol
> to overiding these three functions:
>
> range_adl_begin()
> range_adl_end()
> range_adl_size()
>
> Any comments before I commit?
>

There is a larger question of how to handle ADL customization points in
general. I like the approach you're proposing, but I dislike the naming
of the above functions. The "adl" can go, IMO, and there should be a
"boost" in there somewhere. I suggest:

boost_range_begin()
boost_range_end()
boost_range_size()

In general, boost libraries that use ADL customization points should
name the functions:

boost_[library]_[function]()

The idea is that these overloads are going to appear in users' code, in
their namespace. From a maintenence standpoint, "boost_range_begin"
announces more clearly that this function has to do with the Boost.Range
library than "range_adl_begin".

Comments?

-- 
Eric Niebler
Boost Consulting
www.boost-consulting.com

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk