Boost logo

Boost :

From: John Torjo (john.lists_at_[hidden])
Date: 2005-04-26 05:21:47


>
> Perhaps then BOOST_LOG_DBG() is a better name for the one that can be
> compiled out. Or BOOST_LOGD().
>

Yup, Darren you're completely right.

I will add this facility somewhere this week.

I want to make it so you can twiggle from compile-time or run-time log,
when you declare the log, like this:

// tests with 'is_log_enabled()'
BOOST_DECLARE_LOG(some_log).
// in release mode, completely turned off
BOOST_DECLARE_LOG_DBG(some_log).

Best,
John

-- 
John Torjo,    Contributing editor, C/C++ Users Journal
-- "Win32 GUI Generics" -- generics & GUI do mix, after all
-- http://www.torjo.com/win32gui/ -v1.6.3 (Resource Splitter)
-- http://www.torjo.com/cb/ - Click, Build, Run!

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk