Boost logo

Boost :

From: Manfred Doudar (manfred.doudar_at_[hidden])
Date: 2006-09-14 22:14:02


On Fri, 15 Sep 2006 03:01:07 +0100
"Andy Little" <andy_at_[hidden]> wrote:

>
> "Manfred Doudar" wrote
>
> > If your dot product is indeed an inner product, then an
> > inner_product is what you should call your op - being explicit
> > rather than suggestive is always better (, sorry, just that my
> > mathematics grounding makes me speak out on this one).
>
> Dunno, but FWIW , from the source code:
>
> http://tinyurl.com/e7729
>
> involving transform of a homogeneous 2D coordinate (3 elements) by a
> 2D transform matrix (9 elements)
> here's the resulting assembler of my latest CVS version in VC8 with
> optimisation. I'm no expert but it looks pretty good to me
>
> ; 113 : // do runtime calc
> ; 114 : quan::fusion::dot_product dot;
> ; 115 : result_type result(
> ; 116 : dot(coordinate,col0),
> ; 117 : dot(coordinate,col1),
> ; 118 : dot(coordinate,col2)
> ; 119 : );
>

Please see my brief reply to Geoffrey Irving; ... and apologies for any
apprehension caused, but its my fault - the best name to use really
depends on context.

Cheers,

-- 
Manfred Doudar - Research Engineer
National ICT Australia - Canberra Research Lab | www.nicta.com.au
Research School of Information Sciences and Engineering (RSISE)
The Australian National University - Canberra, ACT 0200 AUSTRALIA

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk