Boost logo

Boost :

From: Steven Watanabe (steven_at_[hidden])
Date: 2007-08-08 19:18:58


AMDG

Eric Niebler <eric <at> boost-consulting.com> writes:

> > I strongly dislike ordered_inserter. Its name
> > indicates to me that it adds elements to a time_series--not
> > at all that it deletes all pre-existing elements. I would
> > expect it to overwrite the old elements only where a new
> > element is specified.
>
> That's a valid criticism. Can you suggest a better name?

I can't say that I'm really comfortable
with the way ordered_inserter works regardless
of the name. I would like it to behave something
along the lines of:

The inserter puts elements directly in the series eliminating
the need for commit. It is an error when the series has elements
after the offset of the inserter. An inserter is invalidated
when the container is modified without using the iterator.

Is there some reason why this doesn't work? If I need the
other behavior I can always create a new series fill it and swap
myself.

In Christ,
Steven Watanabe


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk