Boost logo

Boost :

From: Brook Milligan (brook_at_[hidden])
Date: 2007-09-18 00:50:12


Many of the graph algorithms, e.g., dag_shortest_paths(), combine edge
weights to form distances along a path through the graph. Although
the default combine functor is based on addition, quite general ones
may be used. The naming of the distance_zero() named argument is
apparently based on the fact that zero (0) is the identity for
addition. However, for more general combine methods, zero (0) may not
be an identity. Indeed, the latter, i.e., identity, not the former,
i.e., zero (0), is in fact the relevant property for this argument
with respect to the algorithms. Consequently, it seems that this
argument is misnamed.

As part of the revision of the graph library, I suggest that this
named parameter be relabeled to distance_identity(). That would
capture its general meaning, regardless of the nature of the combine
method.

Cheers,
Brook


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk