Boost logo

Boost :

From: Phil Bouchard (philippe_at_[hidden])
Date: 2008-03-13 02:42:52


"David Abrahams" <dave_at_[hidden]> wrote in message
news:87skyvltul.fsf_at_gutsy.luannocracy.com...

[...]

> If I understand correctly, none of this code is technically portable; it
> is only "portable in practice" because of the way C++ is commonly
> implemented. Is that correct?
>
> It's not necessarily an argument against these proposals, but all Boost
> library submissions should be very clear about where they rely on
> unspecified or undefined behavior.

No it is perfectly portable, this function called "roofof" simply cannot be
applied to classes having virtual inheritance. It can be kept as an
internal routine quite simply and used with PODs and classes having simple
inheritances.

sh::list<> and sh::stack<> classes can be used for different things also. I
will write a pool allocator quickly using sh::list<> with the sh::roofof<>
function for demonstration. I will also rename these for
sh::intrusive_list<> and sh::intrusive_stack<>.

-Phil


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk