Boost logo

Boost :

From: Joe Gottman (jgottman_at_[hidden])
Date: 2008-05-28 20:21:05


Beman Dawes wrote:
> Beman Dawes wrote:
>> John Maddock wrote:
>>> Beman Dawes wrote:
>>>> There is a practical limit on the length of names because the config
>>>> mechanism uses them for file names. But perhaps we can make them less
>>>> cryptic, and still hold them to a reasonable length, say 32
>>>> characters.
>>> It's not absolutely essential for the test filenames to have the same name
>>> as the macro - as long as you can find one from the other :-)
>>>
>>> Personally I'd go for more descriptive names as well,
>> That's my preference too, so since we aren't limited by filenames, here
>> is a more explicit set (taking into consideration comments from Doug and
>> others):
>>
>> BOOST_NO_DECLTYPE // no decltype
>> BOOST_NO_LONG_LONG // no [unsigned] long long type
>> BOOST_NO_RVALUE_REFERENCES // no r-value references
>> BOOST_NO_STATIC_ASSERT // no static_assert
>> BOOST_NO_VARIADIC_TEMPLATES // no variadic templates
>> BOOST_NO_SCOPED_ENUMS // no enum class
>> BOOST_NO_RAW_LITERALS // no raw character or string
>> // literals
>> BOOST_NO_UNICODE_LITERALS // no Unicode literals
>> BOOST_NO_UNICODE_CHAR_TYPES // no char16_t or char32_t
>> BOOST_NO_EXPLICIT_CONVERSION_OPERATIONS // no explicit operator T()
>> BOOST_NO_DEFAULT_FUNCTIONS // no = default functions
>> BOOST_NO_DELETED_FUNCTIONS // no = delete functions
>> BOOST_NO_CONSTEXPR // no constexpr
>
> BOOST_NO_EXTERN_TEMPLATE // no extern template
>
>> Iff voted into the WP:
>> BOOST_NO_CONCEPTS // no concepts

    BOOST_NO_LAMBDA_FUNCTIONS

Joe Gottman


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk