Boost logo

Boost :

Subject: Re: [boost] [Boost-users] Formal Review: Boost.RangeEx
From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2009-02-22 06:40:05


Neil Groves skrev:
> Thank you for taking the time to review Boost.RangeEx.
>
> On Sat, Feb 21, 2009 at 11:50 AM, Christopher Jefferson <
> chris_at_[hidden]> wrote:

>> 2) Why isn't overwrite just an overload of copy?
>
>
> I assumed that overload resolution would be problematic since the range and
> the iterator overloads have the same number of parameters, and the iterator
> version has to handle raw pointers etc. I may be under-estimating the
> meta-programming techniques of enable_if. I will perform some
> experimentation on old compilers and see how well they handle the change.

I guess there are two reasons:

1. overwrite is a more explicit name for what is going on.

2. without concepts, we can't tell if a template argument is a range or
an iterator

In addition, overwrite should use memcpy() when possible.

-Thorsten


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk