Boost logo

Boost :

Subject: Re: [boost] scoped_ptr deleter
From: Gottlob Frege (gottlobfrege_at_[hidden])
Date: 2009-09-16 12:10:40


On Wed, Sep 16, 2009 at 11:47 AM, Howard Hinnant
<howard.hinnant_at_[hidden]> wrote:
>
> const unique_ptr<MyClass, MyDeleter<A>> p(...);
>

scoped_ptr<MyClass, MyDeleter<A>> p(...);

>
> -Howard
>

If you had the scoped_ptr as you described, which would you then use -
const unique_ptr or scoped_ptr?
My first thought is that scoped_ptr is better named, making it easier
to understand for readers/maintainers.
?

Tony


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk