Subject: Re: [boost] New name of bjam.exe
From: Vladimir Prus (vladimir_at_[hidden])
Date: 2010-07-20 06:53:59
Stewart, Robert wrote:
> Brian Ravnsgaard Riis
>> On 20-07-2010 12:05, Artyom wrote:
>> > "build" is not good as it some kind of "namespace pollution",
>> > and is very problematic for systems with single "bin" path
>> > - as most Unix like OSs.
>> > So you need something unique starting with boost prefix as
>> > namespace.
>> > For example all mysql utilities start with mysql prefix
>> > thus I think boost build should be something like
>> > boost_build or boostbld, not really matter, the point is
>> > clear.
>> It is indeed, but I don't actually think I agree... except
>> that "build" is too generic. This command will be typed into
>> a console a hundred times a day in some cases, so it should be
>> rather short. "bjam" was good in this regard, but not really
>> accurate any longer, as Volodya states.
> I disagree with your rationale. First, command history is available in all shells, even cmd.exe
> on Windows, so one isn't likely to type the name hundreds of times per day. Second, there are
> numerous mechanisms available for shortening a long name when that proves desirable, without
> imposing a single short name on all.
> My suggestion: build_boost. While "boost" isn't a prefix in that name, it reads very nicely in
> English. Furthermore, if "Boost.Build" remains as a library/project name, then the reversal in
> "build_boost" is useful to avoid conflation of the two names. That is, the binary isn't the
> library/project and vice versa, so distinct but related names are useful.
But, "build_boost" sounds like a command that, well, "builds" something called "boost", no?
And Boost.Build has significant use to build things that are not "Boost C++ Libraries".
Boost list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk