Subject: Re: [boost] Boost.Local Review (Nov 10, 2011 to Nov 19, 2011)
From: Christian Holmquist (c.holmquist_at_[hidden])
Date: 2011-11-14 18:06:51
On 14 November 2011 15:32, Jeffrey Lee Hellrung, Jr. <
> On Mon, Nov 14, 2011 at 1:26 PM, Vicente J. Botet Escriba <
> vicente.botet_at_[hidden]> wrote:
> > Le 14/11/11 19:15, Jeffrey Lee Hellrung, Jr. a écrit :
> >> I think Boost.Scope or Boost.Scoped wouldn't be bad names for a merged
> >> library (the current name Boost.Local I think is also fine).
> > I don't know if in English Locale and Local sound enough different, but
> > for me there is no big difference. I will prefer a distinct name.
> Well, they certainly *sound* different (they accent different syllables),
> but the closeness in spelling is certainly a consideration.
> AFAIK, no one else has brought up this issue yet (except gmail's
Boost.Local is the only library this far in Boost that I have to silently
pronounce in my head before I realize that it's not Boost.Locale.
Since the two libraries for a while was active on the mailing list at the
same time, it did cause me some confusion in the beginning.
I'm very easily confused, however, so quite possible I'm the only one
seeing this as a problem :)
That said, it's absolutely no big deal, but I think it would be better if
the names were not so closely named..
Boost list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk