![]() |
Boost : |
From: Steven Watanabe (watanabesj_at_[hidden])
Date: 2025-05-10 17:22:06
AMDG
On 5/8/25 8:13 PM, Jean-Louis Leroy via Boost wrote:
> <snip lots>
>
>> Switching the default policy based on NDEBUG is dangerous. It's
>> not uncommon to link code build with NDEBUG to code built without it.
>
> Hmmm yes I see that. I am completely separating the release and debug policies
> in the new design of the policy system. default_policy is a typedef, and, if I
> understand properly, having a typedef aliasing to different types is not an ODR
> violation in itself, but it makes it easier to create one.
>
> Do you have a better suggestion?
>
My preference would be to make release the default and
leave debug to be specified explicitly.
>> I don't understand the name vectored_error_handler. How is it vectored?
>
> I guess it's boomer-speak... We used to call indirect function calls "vectored".
> Do you have a better name?
>
I guess I can see that. It's just that, in a C++ context,
when I see vector I immediately think std::vector, which
is a completely different meaning of the word.
Some random ideas:
dyn_error_handler
runtime_error_handler
default_error_handler
>> policies/vptr_vector.hpp:
>> 32: Does using namespace policies do anything?
>
> It imports the names in the current scope? ;-) I do that in the body of some
> functions.
It just looks odd because policies /is/ the current namespace.
In Christ,
Steven Watanabe
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk