From: Rene Rivera (grafik666_at_[hidden])
Date: 2002-03-07 20:27:04
On 2002-03-07 at 07:09 PM, david.abrahams_at_[hidden] (David Abrahams) wrote:
>----- Original Message -----
>From: "Thomas Witt" <witt_at_[hidden]>
>> I finally managed to write the documentation for the proposed new
>I like it! A full doc patch would be in HTML, of course...
But it's much easier to read and comment on it this way ;-)
On second viewing I like this concept, more and more. Even though it's not as
orthogonal as dividing up the sources, requirements, and builds, it is easier
to understand as a single construct than multiple ones.
>> Please note that the documentation describes template as I
>> initially wanted it to be. Note that the supplied patch does not fully
>> implement template as it is documented it only cares about the
>I didn't get a patch. Did you post one?
I think Thomas is referring to the original files. Thomas how likely is it
that we can get an updated set of files? Preferably based on the current CVS
>> There were already a few comments on the name and further design
>> left these out so that you can see what I want to achieve. This does
>> I think they are all wrong.
>> As for the name I think requirement-set is not a suitable name for
>> it is documented. Its scope goes well beyond requirements. If we
>> the requirement portion is needed requirement-set would certainly be a
>> name for such a thing.
>I agree with you, and wouldn't like to limit the scope. Just
>experimenting with different names, how does "base" sound to you?
How about "prototype", as in one is defining a prototype of a target. Using
template reminds too much of the C++ template, and base is too common of a
name, it's even in the example :-)
>> Dave, I still think the analogy between templates and targets is ok.
>> things _are_ pretty much like targets. Basically they are incomplete
>> I hope the documentation makes this clear.
>Yes, it does.
And naming it "prototype" I think makes this even clearer!
Also as far as the previous discussion about having "global" or C++ style
scope names... I think I'm OK with not having that and leaving it as is. When
we get the additional project support in V2 we should be able to then refer to
project rooted names so this is not really a concern.
-- grafik - Don't Assume Anything
-- rrivera_at_[hidden] - grafik_at_[hidden]
-- 102708583_at_icq - Grafik666_at_AIM - Grafik_at_[hidden]
Boost-Build list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk