Boost logo

Boost-Build :

From: David Abrahams (dave_at_[hidden])
Date: 2003-01-15 09:09:54

Vladimir Prus <ghost_at_[hidden]> writes:

> David Abrahams wrote:
>>>Hmm.. I recall you were saying <toolset-version> is not for users to
>>>specify. Did you change your mind?
>> Not sure whether I meant that I wanted to prohibit it, or just that
>> they were unlikely to specify it. The latter seems more likely.
>> However, what I'm concerned about is that some of our code will do
>> validation after expansion, and that shouldn't cause an error.
> I believe that we shouldn't to validation twice, first of all.

In principle, I agree.

> Don't know if this is hard to achive.

Yeah, it's the "in practice" I was worried about. But I also worry
that it's very arbitrary to prohibit people from specifying
toolset-version, especially if it eventually shows up in their error
messages or Jamfiles somehow.

> Futher, errors about <toolset-version> are easy to debug...


David Abrahams
dave_at_[hidden] *
Boost support, enhancements, training, and commercial distribution

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at