On Mon, Dec 30, 2013 at 6:20 PM, Tom Kent <lists@teeks99.com> wrote:
>
> The old SVN behavior was that unless you pass
> --incremental or --force-update, the regression
> scripts would try to delete the sources and
> check them out from scratch.
>

Maybe we should re-evaluate the default here for git. It seems like
what was the --force-update would be a better default than trying to
re-clone the entire repo each time.

Does anyone remember the history of why it was set like this for svn?

I'm guess that the script started out with few if any options, and that as options were added the default was always the original behavior so as not to break the setups for existing test runners. But regardless of the past motivation, we should look at each of the commands and options at be sure that the name and (for options) default behavior make sense for git and modular boost. Where the effect of an option is to execute a command, it also might be clearer if the option name was the same as the command name.

See http://beta.boost.org/development/running_regression_tests.html

So in a git world:

--force-update should be the default behavior as Tom suggests, and the --force-update option should be removed. The "get-source" command could be renamed "clone", a "--clone" option added, and the "update-source" command renamed "pull".  Alternate names might be "clone-repo", "clone-super-project", "pull-repo", "pull-super-project" or similar.

--incremental should be the default behavior, and the --incremental option should be removed. A "--test-clean" option should be added, mimicking the name of the equivalent command.

Does the --local option make any sense in a git world?

--Beman

--Beman