Boost logo

Boost Users :

From: Maciek Godek (pstrychuj_at_[hidden])
Date: 2007-07-09 15:35:15


Wouldn't it be better if boost::lambda::bind was named
boost::lambda::call (or boost::lambda::eval, to make it more lispish),
in order to:

-avoid the confusion and potential overlap with boost::bind

-make the name more sensible within lambda expressions, especially
when "binding" nullary functions, ie.

int six() { return 6; }

if_(call(six) == 6) [ ... ]

IMHO looks better than

if_(bind(six) == 6) [ ... ]

Yours,
Chuj


Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net