Boost logo

Boost Users :

Subject: Re: [Boost-users] Boost.Log formal review upcoming
From: Kevin.Stevens_at_[hidden]
Date: 2010-03-01 10:12:06


I just took a look at the documentation, and I must say this looks great, I am looking forward to testing it out. A few things I noticed in the docs:

>From the macro documentation page, it is unclear as to whether the build system will make any attempt to detect the platform you are on and enable BOOST_LOG_USE_WINNT6_API if you are on a Vista+ machine. I am guessing not, but that could be made clearer.

You solved a problem that I saw with previous versions of logging libraries here- you made the simple case of just putting severity levels on a message and putting it somewhere easy, without a lot of set up required. However, I feel a better name for the macros would be BOOST_LOG_SIMPLE, not BOOST_LOG_TRIVIAL. Its shorter, which is always nice, especially considering intellisense tends not to deal with macros so well in my experience, and I guess I have a bit of PTSD from being in university and often having professors gloss over details in lectures because they are supposed to be trivial, and they... were not. Whether I am being overly picky/quirky or not, you can decide.

The biggest thing missing from the page is performance comparisons with other libraries, notably log4j/log4cxx, and throughput numbers with various features enabled. For my project, this is pretty much a dealbreaker that would prevent me from using the library, at least not before doing lots of tedious testing (which considering I am already using log4cxx and it works, I would not waste time doing). Performance is tremendously important for our applications, and excessive logging is too often a cause of performance problems, as well as getting too fancy with certain features (log4cxx takes a large hit to performance if you include the class name in the logging output, which IIRC is due to RTTI being used), if there are similar gotchas here, they should be noted.

-Kevin

-----Original Message-----
From: boost-users-bounces_at_[hidden] [mailto:boost-users-bounces_at_[hidden]] On Behalf Of Eric J. Holtman
Sent: Monday, March 01, 2010 8:38 AM
To: boost-users_at_[hidden]
Subject: Re: [Boost-users] Boost.Log formal review upcoming

Roland Bock wrote:
>
> For instance, instead of
>
> BOOST_LOG_SEV(slg, normal) << "A regular message";
>
> I'd like to use something like
>
> slg.log(normal) << "A regular message";
>

Pretty sure that's done for performance, so that if the thing being logged is a complex expression, but yet could be trivially filtered, it is not evaluated.

_______________________________________________
Boost-users mailing list
Boost-users_at_[hidden]
http://lists.boost.org/mailman/listinfo.cgi/boost-users
_______________________________________________

This e-mail may contain information that is confidential, privileged or otherwise protected from disclosure. If you are not an intended recipient of this e-mail, do not duplicate or redistribute it by any means. Please delete it and any attachments and notify the sender that you have received it in error. Unless specifically indicated, this e-mail is not an offer to buy or sell or a solicitation to buy or sell any securities, investment products or other financial product or service, an official confirmation of any transaction, or an official statement of Barclays. Any views or opinions presented are solely those of the author and do not necessarily represent those of Barclays. This e-mail is subject to terms available at the following link: www.barcap.com/emaildisclaimer. By messaging with Barclays you consent to the foregoing. Barclays Capital is the investment banking division of Barclays Bank PLC, a company registered in England (number 1026167) with its registered office at 1 Churchill Place, London, E14 5HP. This email may relate to or be sent from other members of the Barclays Group.
_______________________________________________


Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net