According to header file boost/utility/typed_in_place_factory.hpp (as linked from documentation: http://www.boost.org/doc/libs/1_55_0/boost/utility/typed_in_place_factory.hpp) typed_in_place_factory has member type value_type which is the constructed type.

Yet documentation (http://www.boost.org/doc/libs/1_55_0/libs/utility/in_place_factories.html) fails to mention it. Why? Is it not part of the interface (I would assume so based on not mentioning it in documentation...)? Or was it just forgotten? I find such value_type quite useful...

And since I'm already writing let me note that the mentioned documentation has also another minor issue. In Specification section the sample in_place_factory and typed_in_place_factory should be named in_place_factory1 and typed_in_place_factory1. As this is how they are really named. Or it should be stated explicitly that the actual name is implementation dependent.

Adam Badura