Boost logo

Boost :

From: Kevlin Henney (Kevlin.Henney_at_[hidden])
Date: 1999-06-15 13:46:35

This is always an interesting one. I must confess that I've never been that
keen on "nonary_function" and related naming schemes. It is not really
common usage, and there is always the interesting pronunciation "nunnery
function", which does not perhaps evoke quite the right imagery :->

"nullary_function" might be considered more in spirit, as null, unary and
binary are all derived from Latin. A quick search through a couple of
references does not reveal much of use, as the absence of side effects in
real FP means that zero place functions are just constants, and
"constant_function" definitely gives the wrong impression in the context of

My own practice in the past has been to simply drop the prefix, ie



Nicolai Josuttis <nicolai.josuttis_at_[hidden]> on 15/06/99

Please respond to boost_at_[hidden]

To: boost_at_[hidden]
cc: (bcc: Kevlin Henney/QA Training Ltd)
Subject: [boost] nonary_function OK?

A related discussion to the compose discussion:
I have also introduced type nonary_function as supplement for
unary_function and binary_function for functions that take
no arguments.
 Is the name nonary_function fine or should I use another name
 (e.g. Kevin van Horn uses in his functor extensions
  nullary_functions as far as I know) ?


eGroups now offers FREE email newsletters!, RollingStone, Travelocity, and more?
Sign-up Now! home: - Simplifying group communications

------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at