Boost logo

Boost :

From: Nicolai Josuttis (nicolai.josuttis_at_[hidden])
Date: 1999-07-04 04:19:40

I don't like that the programmer still has to
know whether he has to use erase_sequence() or erase_node_based().

A long time ago I discussed with Matt a more general approach.
The introdution of container_traits.
With container_traits we could implement algorithms and functions
that automatically use the best way to process the operation
(just the way distance() and advance() operate for iterators).
So, the programmer has just to say what he want without
thinking about it (OK, a programmer should better know what he does, but ...)
E.g. we could define container categories such as
 sequence_container, associative_container, node_based_container
or just the name of the container (vector_container etc.).
Unfortunately, this is an extension inside the container
classes, so we caan't ship it as separate extension.
But it would be worth it to force this concept.
Let's make a concept for container_traits that would fit
all meeds best and force implementors to implement it.
Then we could ship a lot nice and easy interfaces for the STL.

Nicolai M. Josuttis
Solutions in Time
------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at