Boost logo

Boost :

From: Dave Abrahams (abrahams_at_[hidden])
Date: 1999-09-19 22:21:12

> - polymorphic_downcast<> is poor name because it's for upcasts too
> + change name to polymorphic_static_cast<>

Disagree. It's only for what I designed it for ;)
Why would you use it for upcasts when implicit conversion does that

> - polymorphic_downcast allows incorrect casts that arise in presence of
> multiple inheritance
> + change implementation to use stronger assert


> - some users of casts.hpp may prefer asserts instead of exceptions
> + make version of casts.hpp that can do asserts instead of exceptions
> (use two different namespaces and determine which to import into boost with
> a compile-time switch; exception version should be default)

Now you're talking about the numeric casts, right?


> Once these casts are used, a search for static_cast and reinterpret_cast in
> a program should find only questionable casts. Typical uses will use the
> boost casts, const_cast, or dynamic_cast instead.

const_cast isn't questionable? ;)

Boost list run by bdawes at, gregod at, cpdaniel at, john at