Date: 1999-11-28 16:22:41
Dave Abrahams writes:
> I was trying to suggest moving incrementable, decrementable, and
> dereferenceable into operators.hpp. If neccessary it would be OK to modify
> the copyright as appropriate. It just seems like people will want to find
> those operators all in one place.
Sure that's fine by me. I'd just ask that my name stays in there.
> > and how about
> > random_access_operator -> randomly_accessible<T>
> I was thinking that there might be a better name. After all, it isn't T that
> can be randomly accessed, but what T refers to. Perhaps "indexable"?
"indexable" works for me.
> Well, it might make sense for ease-of-use to provide defaults for things
> like the distance, pointer, and reference types (especially the latter two).
> Unless someone is making a proxy iterator (a subject which could use some
> good research), the pointer and reference types can be automatically derived
> from the value type. I vote for iterator_traits<char*>::distance_type as a
> default for the distance type.
Ahh. I'm use to dealing with pointers with weird reference types, but
what you suggest does make sense for defaults.
> P.S. Thank you for being so receptive to my suggestions!
No problem, it's nice to get the feedback. I'm use to working on my own
and sometimes it gets tiresome trying to think of everything on your
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk