Boost logo

Boost :

From: Howard Hinnant (hinnant_at_[hidden])
Date: 1999-12-15 12:53:50

I would imagine that little implementation namespaces are (or soon will
be) common in boost libraries. Namespace aware browsers might have the
ability to hide and show, based on a namespace name. Instead of
presenting a zillion little implementation detail namespaces to such a
browser, how 'bout if boost libraries standardize on a common
"implementation detail" namespace. Then it would be easy for the user of
a namespace aware browser to "show boost", but hide "boost::details".

Assuming this is a good idea, here are a few suggested names for this
nested namespace:

1. boost_implementation
2. implementation
3. imp
4. details
5. rel_ops

I think 1 and 2 are too long, making it too hard to read the
implementation of a boost lib. 3 is a little short and ambiguous. I
like 4 the best. But I think 5 is really funny. We all know how
effectively std::rel_ops hides its contents from client code! :-)

Beman Dawes wrote on 12/15/99 11:53 AM
>Interesting idea!
>boost::details looks good to me, but, hey, rel_ops has a long and
>[in]glorious history:-)
>Howard, you might want to repost your idea as a separate thread, so
>people who are skipping the call_traits/type_traits discussion won't
>miss it.


Boost list run by bdawes at, gregod at, cpdaniel at, john at