Boost logo

Boost :

From: Nicolai Josuttis (nicolai.josuttis_at_[hidden])
Date: 2000-01-03 13:32:21

Darin Adler wrote:
> Name suggestions:
> My favorite of the ones already mentioned: array.
> Names I like: fixed_size_vector, sized_vector.
> Other variations: fixed_size_array, fixed_vector, fixed_array,
> sized_array
seems that array is the winner...

> > In addition, he introduces op==, op<, swap(), and reverse iterators.
> Those are good additions. I'd want to include a few other things that are in
> both vector and deque in the class for a little more flexibility in generic
> programs:
> assign();
> empty(); // true for zero-sized instances
> at();
> front();
> back();
> operators !=, >, >=, <=
OK, no problem.

> I'd also like to have a nice way to copy a non-carray-wrapped array into the
> carray and vice versa in a way that creates a compile-time error if the
> length is wrong. Probably this could be done some free function templates
> that could use the stuff in <array.hpp>.
> -- Darin

Nicolai M. Josuttis 
Solutions in Time        	mailto:solutions_at_[hidden]

Boost list run by bdawes at, gregod at, cpdaniel at, john at