Boost logo

Boost :

From: jsiek_at_[hidden]
Date: 2000-01-09 12:34:16

Dave Abrahams writes:
> I support providing a wrapper for the ordinary pointers in which so much
> existing code traffics. It doesn't bother me that we might have two
> different array wrappers. I think the proposed name could be improved, and
> that would solve some of the problems of the existing proposal.
> array_ptr would be a better name. After all, 1. it is a wrapper for a
> pointer 2. we don't expect these objects to behave like references when
> assigned, do we?

Right, I was already thinking of the name ptr_array as a replacement :)

> There may be even better names possible, but first we ought to address the
> following:
> Q: Why are we doing this? A: to write generic code which uses a subset of
> the Container requirements.
> Do we have a name for the concept you want to make available? [I regret that
> the standard library has defined "Container" to be something so very
> specialized, and which does not include so many things we'd like to call
> Containers]

Good call. How about "Collection"?

> > so it would be ok to use the reversible_container_helper
> > (which perhaps should be added to boost/operators.hpp).
> I would not support adding that to operators.hpp, since it has little to do
> with the original purpose of that header as reflected in its name. Probably
> the stuff devoted strictly to iterators should be separated into another
> file if you feel strongly that this class is related to that stuff.

Or maybe have a new file devoted to container helpers (you are right,
it's not that related)


Boost list run by bdawes at, gregod at, cpdaniel at, john at