Boost logo

Boost :

From: Dave Abrahams (abrahams_at_[hidden])
Date: 2000-01-18 23:16:02

> Maybe, "inp_iterator_adaptor" and "out_iterator_adaptor"
> can save some typing. Anyway, if there is "shared_ptr" and not
> "shared_pointer", why not establish "iter" as an abbreviation for
> "iterator"?

Er... because of the "auto_ptr" precedent in the standard, um I mean the
"std". I don't have a better excuse than that.

But we've been trying to keep the abbreviations in boost to a minimum. If
you want a shorter name for these pipers, could you please make an effort to
find a good name that includes no abbreviations? I guess your original names
could be considered to fit the bill... Okay, I abstain on the name for these


Boost list run by bdawes at, gregod at, cpdaniel at, john at