Boost logo

Boost :

From: Dave Abrahams (abrahams_at_[hidden])
Date: 2000-01-27 21:56:17

> Well, it means *everyone* has to put their property accessors in
> namespace boost, and it clutters up your algorithm code. It
> was bad enough moving away from operator[] to set/get, but
> boost::set, boost::get is even worse! Check out the following
> algorithm, which version is more readable?

First of all, is there really a conflict? A function called set() doesn't
conflict with a class template called set<>, does it? Can you show an
example where the conflict occurs?

Second of all, can't people put their property accessors in their *own*


Boost list run by bdawes at, gregod at, cpdaniel at, john at