Boost logo

Boost :

From: Darin Adler (darin_at_[hidden])
Date: 2000-02-04 13:13:18

> Let's see if we can do better that temp_value or temporary_value for names.
> How about auto_save or auto_restore? Or has auto_ptr given auto_... names
> a bad name:-)

I think auto_restore is a good name.

For what it's worth, the most-used Macintosh application framework,
Metrowerks' PowerPlant, has the same class as the proposed one. It changes
the value and as in our latest proposed version, it takes a reference as the
first constructor parameter and a const reference as the second. Its name is
"PowerPlant::StValueChanger". The St prefix is pretty silly; it is used to
indicate "I expect this will be used for the type of an automatic variable".

    -- Darin

Boost list run by bdawes at, gregod at, cpdaniel at, john at