|
Boost : |
From: Stephen C. Gilardi (squeegee_at_[hidden])
Date: 2000-02-06 13:13:19
Perhaps names more inline with the intention of temporarily setting a
value and being assured that it will be restored at the end of the
block would be"
"scoped_push_value" or
"block_push_value"
We are treating this like a temporary push to the top of a "stack" of
values for the given variable.
How does this sound for readability:
{
block_push_value push(mDisableUpdates, true);
block_push_value push2(mEnableLogging, true);
}
--Steve
>More name suggestions:
>
> assigner
> auto_assigner
> safe_assigner
>
> value_changer
> value_setter
> auto_value_changer
> auto_value_setter
>
> auto_changer
> safe_changer
>
> -- Darin
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk