Boost logo

Boost :

From: Miki Jovanovic (miki_at_[hidden])
Date: 2000-02-23 14:11:13

"mark borgerding" <mborgerdin-_at_[hidden]> wrote:
> I place a great deal of importance on a name. The name
> of a class is the first clue that a user has to its function. I
> that "abc" is just a placeholder, is there another name you had
> of? The name "abstract" jumps to mind, but it is not entirely
> descriptive, since as soon as it is derived, the condition is met.
> I am assuming something like this would be the definition.
> class abstract { virtual ~abstract() =0 {} };

Oh, sorry I thought it was obvious:

ABC = Abstract Base Class


Miki Jovanovic.

Boost list run by bdawes at, gregod at, cpdaniel at, john at