Boost logo

Boost :

From: Tim Sharrock (tim_at_[hidden])
Date: 2000-05-05 06:29:42

> Tim says:
> > I would perhaps suggest though, that "compact_vector" might be a
> > better name for this proposal, as it is optimised *differently* to
> > std::vector, rather than in all respects
> Actually optvect comes from "(asymptotically) optimal vector", because
> you cannot do any better asymptotically. However, I like
> compact_vector better. But I will think about this later. Maybe
> someone has an even better proposal

I see! My interests tend to lie in lots of small collections, rather than
a few big ones, so the asymptotic case is only occasionally of interest to
me (other people of course will have different requirements)


Boost list run by bdawes at, gregod at, cpdaniel at, john at