Boost logo

Boost :

From: Peter Nordlund (peter.nordlund_at_[hidden])
Date: 2000-05-25 04:26:50


Hi all,

In the spirit of noncopyable I suggest that the class

class noninstantiable {
    private:
      noninstantiable(){}
}; // noninstantiable

is added to utility.hpp.

Inherit from this class if your class should not be possible to
instantiate.
E.g when your class only contain static functions.

If someone has a better name to suggest you are wellcome!

(By the way it seems to me that the 2 include directives in utility.hpp
could be removed.)

Regards,
Peter


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk