Boost logo

Boost :

From: Tomasz Kowalczyk (tomek_at_[hidden])
Date: 2000-05-28 01:37:42

Nicolai Josuttis wrote:
> Hi Beman, hi all others,
> late but hopefully not too late attached here
> is a new version of class array<>.
> I have improved a lot of things including a detailled description
> of this class, several examples and a discussion of the tradeoff
> between
> - being an aggregate
> - being unable to have uninitialized values
> Comments are welcome.
> Esspecially regarding the initialization stuff.
> Hope it helps.

I have a comment about the naming of this class. I am afraid that
"array" has potential to be used for other things than just a wrapper
around C arrays. Why not to call it a "carray" so that everybody knows
what it refers to, and so that long threads in clc++m about stealing
names and introducing confusion can be avoided ?

IMHO "array" should rather refer to something like "Array" in blitz++


> Nico
> --
> Nicolai M. Josuttis
> Solutions in Time mailto:solutions_at_[hidden]
> [Non-text portions of this message have been removed]
> ------------------------------------------------------------------------
> Failed tests, classes skipped, forgotten locker combinations.
> Remember the good 'ol days
> ------------------------------------------------------------------------

Boost list run by bdawes at, gregod at, cpdaniel at, john at