Boost logo

Boost :

From: Ed Brey (brey_at_[hidden])
Date: 2000-06-26 09:51:46

From: "Greg Colvin" <greg_at_[hidden]>
> From: Mark Rodgers <mark.rodgers_at_[hidden]>
>>>"array" is just too generic a name. I prefer "c_array" to "carray", but
>>>the important thing is to pick a name that at least hints at what kind of
>>>array we are talking about.
>>I actually prefer "array". Although we inherited them from C, arrays are
>>part of C++ so why not call a spade a spade? After all, 8.3.4 is not
>>headed "C Arrays".
>I agree. It's real name is boost::array, so we are only stealing
>the name from ourselves.

For a normal library, this would be the case; however, for boost, the
criteria runs a little deeper. Assuming that array is a class for
which we want to develop existing practice in order to determine
suitability for addition into a future version of The Standard, we
should view the cost of the name similar to how we would view the cost
of the name std::array. It would be undesirable to have to change the
name (except for the namespace) during a standardization process
because the benefit of having a tested name would be lost.

The key question I see is what other uses, if any, of std::array would
we be stealing? If there is one or more use that would cause
std::array to seem overly general or ambiguous, then it should be
changed. If there is not, then the name "array" can be judged alone
on its suitability to the class it names.

I'd like to see a brainstorm of what else boost or the standard may
want to use the name "array" for someday. I don't have any ideas for
that personally, and I think the name "array" is very suitable for
this class, so based on what I've seen so far, array seem optimal to

Boost list run by bdawes at, gregod at, cpdaniel at, john at