Boost logo

Boost :

From: Jeffrey D. Paquette (paquette_at_[hidden])
Date: 2000-06-28 10:25:17

>(2) For distinguishing between throwing and nonthrowing versions, I
>tried out a few syntax forms, and found the following style one of most
>convenient and "in the spirit":
> a = interpret_cast<A>(b);
> a = interpret_cast<A>(nonthrowing(b));
>Whichever way we go, I would prefer to keep both forms as cast-like as
>possible. Feelings on this?

Why not go with existing practice and write:

         a = interpret_cast<A>(b, std::nothrow);

for the non-throwing version?

Jeff Paquette
paquette_at_[hidden], paquette_at_[hidden]

Boost list run by bdawes at, gregod at, cpdaniel at, john at