Boost logo

Boost :

From: Greg Colvin (greg_at_[hidden])
Date: 2000-07-23 15:42:22

From: David Abrahams <abrahams_at_[hidden]>
> I totally support all of Howard's arguments below :)

Me too. But what names to use? Howard's names for 'IF'
don't make it so clear what the meaning of the parameters
is. Maybe 'If' would do?

Or if we are feeling very brave, how about something like
   #define If whatever<
   #define Then ,
   #define Else ,
   #define End >::type
so that instead of the inscrutable
   typedef If<flag, type1, type2>::type my_type;
we can write
      If flag Then

And Howard thought he was getting punchy!

Boost list run by bdawes at, gregod at, cpdaniel at, john at