Boost logo

Boost :

From: Beman Dawes (beman_at_[hidden])
Date: 2000-08-15 13:14:08

Howard Hinnant wrote:

>Beman Dawes wrote on 8/15/2000 11:57 AM
>>John Maddock wrote:
>> >I also notice that MWCW is unable to locate header files included with
>> >"header.hpp" if that header is in the same directory as the source
>> >(the problem is libs\utility\type_traits_tests.hpp which has code
>> >several test files), any ideas on the right thing to do here?
>>I tried for awhile to fix that, but must be misunderstanding their
>>documentation. Any CodeWarrior command line experts out there?
>I'm by no means a command line expert. But have you tried -cwd source?
>I see this under the -help output and seems to apply to this situation.

Yep! That is it! I was trying to use combinations of -I and -i.

But... The compile still fails later on:

***** utility/type_traits_test.cpp *****
   Metrowerks CodeWarrior
    mwcc -maxerrors 10 -cwd source -I- -Ic:/boost/site
### mwcc Compiler:
# In: ..\site\boost\detail\type_traits.hpp
# From: ..\site\libs\utility\type_traits_test.cpp
# --------------------------------------------------
# 500: static const unsigned value = sizeof(padded) - sizeof(T);
# Error: ^
# illegal use of incomplete struct/union/class

This looks like a compiler error; padded isn't incomplete as far as I can

I know Metrowerks people are busy getting 6.0 out the door, but once that
ships maybe we can track down the CW compile problems.



Boost list run by bdawes at, gregod at, cpdaniel at, john at