Boost logo

Boost :

From: Kevlin Henney (kevlin_at_[hidden])
Date: 2000-08-31 10:23:50

In message <[hidden]>, Beman
Dawes <beman_at_[hidden]> writes
>How about a common boost cast library, initially with headers
>boost/lexical_cast.hpp and boost/cast.hpp? Names subject to further
>discussion, of course.

Sounds good.

>The documentation would continue to be separate,
>but the library's index.html page would link to the separate docs. To
>ensure consistency and reduce administrivia, all boost cast components
>would be formally reviewed together.

In which case, I'd like to raise a consistency question: What should
throwing casts throw? (1) std::bad_cast, (2) something more specific
derived from std::bad_cast, or (3) something else? My preference is for
(2), but there are already casts with (1) as well (including my own).

>I'd also like to see the nested cast namespace removed from cast.hpp. The
>advantages are limited in relation to the added complexity and reduced code
>readability and writeability.


  Kevlin Henney phone: +44 117 942 2990
  Curbralan Ltd mobile: +44 7801 073 508
  kevlin_at_[hidden] fax: +44 870 052 2289

Boost list run by bdawes at, gregod at, cpdaniel at, john at