From: William Kempf (sirwillard_at_[hidden])
Date: 2000-09-05 08:48:05
--- In boost_at_[hidden], Kevlin Henney <kevlin_at_c...> wrote:
> In message <B5D60D90.2E6%darylew_at_m...>, Daryle Walker
> <darylew_at_m...> writes
> >- The "type_info" name is already used (as a noun; a class name)
in the std
> >namespace, so it looks confusing.
> >- The previous point is made worse by the fact that
the "type_info" class is
> >the return type of the "type_info" method!
> OTOH, it could be argued that as a result of this you know exactly
> you're getting. That is why it is now the way it is. It used to be
> called "type" in previous versions.
> >A much better name would be something like "get_type."
> Definitely not ;-) Although, with hindsight I could be persuaded to
> return to "type".
I like type() better myself, for whatever my opinion is worth.
><lament>why, oh, why can't we have partial specialization of function
I don't know, but it's trivial to work around this. Have the
template function be a simple wrapper around a functor, which can be
partially specialized (on those compilers that allow it).
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk