Boost logo

Boost :

From: John Maddock (John_Maddock_at_[hidden])
Date: 2000-09-06 05:49:53


>Now that there are several boost libraries which have "details" namespaces
>should we be using a namespace with less possible collisions? i.e.
>ggcl_details? any_details?, lambda_details? vtl_details?

Actually I think it started as "detail" singular.
You are correct about collisions though.

>This comes up because I was thinking about making the libraries closer to
>boost conformity and the number of lambda, VTL specific classes is large.
>Leading to possible name collisions, which I'd like to avoid. I was
>about using a define which I could do a global search/substitution but
>why if I could do it right the first time, I'd rather do that. Thoughts?

Also agreed, I have used "re_detail" for the regex private parts, similarly
mangled names for other large libraries seem to be a good idea - but I
guess use whatever you want - vtl_detail, VTL, gp, whatever, as long as it
is private to you.

- John.

Boost list run by bdawes at, gregod at, cpdaniel at, john at