Boost logo

Boost :

From: David Abrahams (abrahams_at_[hidden])
Date: 2000-09-19 19:27:35


----- Original Message -----
From: "jeremy siek" <jsiek_at_[hidden]>
To: <boost_at_[hidden]>
Sent: Tuesday, September 19, 2000 7:19 PM
Subject: Re: [boost] Graph stuff

> David Abrahams writes:
> > Look, it's really not an accessor the way you've defined it... it's
more of
> > a reference. In some sense, it's just like a descriptor - an abstract
> > identifier for the value(s) in question. The accessing all happens
inside of
> > get()/put().
>
> The vertex and edge descriptors refer to a particular object, whereas
> the property accessors are maps from objects to properties. If there's
> a better name for this than "property accessor" I'm all ears.
> (though, for starters I think using "map" would be too mathematical)

Well, actually I think PropertyMap is a fine name for a concept, and much
better than PropertyAccessor.
It does say exactly what it means.

> > Too much, I still think. Something short and sweet would be better. If
you
> > must have "accessor" in the name, then how about
> > "edge_capacity::accessor(G)"?
> > [I still don't like accessor <growl>]
>
> I can live that :)
>
> > > > edge_capacity::get(G, e)
> > > > edge_capacity::put(G, e, c)
> > > >
> > Fine, I have no problem with keeping the generic interface. And one
should
> > use the generic interface for generic algorithms. But what about the
poor
> > user who has built a specific graph and just wants to extract the
least-cost
> > predecessor values from his vertices after running Djikstra?
>
> I can live with adding the above functionality to the adjacency_list
> class,

Is that really an adjacency_list function? I thought it was by definition a
member of the property class (aka "plugin").

> but I'd rather not add this interface to any graph concept.
> That should discourage its use in a graph algorithm.

Can we review the examples I've written about in light of whatever I've
battered <wink> you into accepting? Would you mind writing the examples out
so I can see how they look?

Thanks,
Dave


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk